Сети для самых маленьких. Часть 0. Планирование || Сети для маленьких

Заголовок MPLS

Весь заголовок MPLS — это 32 бита. Формат полей и их длина фиксированы. Часто весь заголовок называют меткой, хотя это не совсем и верно.

Label — собственно сама метка. Длина — 20 бит.TC — Traffic Class. Несёт в себе приоритет пакета, как поле DSCP в IP.Длина 3 бита. То есть может кодировать 8 различных значений.Например, при передаче IP-пакета через сеть MPLS значению в поле DSCP определённым образом ставится в соответствие значение TC.

Таким образом пакет может почти одинаково обрабатываться в очередях на всём протяжении своего пути, как на участке чистого IP, так и в MPLS.Но, естественно, это преобразование с потерями — шести битам DSCP тесно в 3 битах TC: 64 против 8. Поэтому существует специальная таблица соответствий, где целый диапазон — это всего лишь одно значение.

=====================Задача № 1

В сети настроена простая политика QoS, в которой IP-пакеты, которые идут с хоста 10.0.17.7 на адрес 6.6.6.6, маркируются и передаются по сети MPLS. Для маркировки пакетов используется поле EXP, значение поля 3.

Сети для самых маленьких. Часть 0. Планирование || Сети для маленьких

На маршрутизаторе R6 настроена политика QoS, которая классифицирует пакеты по полю EXP. Но, при проверке оказалось, что политика на R6 не отрабатывает. То есть, нет пакетов, приходящих со значением EXP 3 и все пакеты попадают в class default.

Задание: Исправить конфигурацию так, чтобы политика на R6 срабатывала.

Маршрутизатор R7 используется в качестве клиента. Соответственно MPLS между R7 и R1 не включен.

Подробности задачи и конфигурации тут.=====================

Документация сети

Вся сеть должна быть строго документирована: от принципиальной схемы, до имени интерфейса.

Прежде, чем приступить к настройке, я бы хотел привести список необходимых документов и действий:

  • схемы сети L1, L2, L3 в соответствии с уровнями модели OSI (физический, канальный, сетевой);
  • план IP-адресации = IP-план;
  • список VLAN;
  • подписи (description) интерфейсов;
  • список устройств (для каждого следует указать: модель железки, установленная версия IOS, объем RAMNVRAM, список интерфейсов);
  • метки на кабелях (откуда и куда идёт), в том числе на кабелях питания и заземления и устройствах;
  • единый регламент, определяющий все вышеприведённые параметры и другие.
Предлагаем ознакомиться:  Самый маленький спиннинг

Жирным выделено то, за чем мы будем следить в рамках программы-симулятора. Разумеется, все изменения сети нужно вносить в документацию и конфигурацию, чтобы они были в актуальном состоянии.

Маркировка кабелей и устройств
Маркировка кабелей и устройств

На этой фотографии отлично видно, что промаркирован каждый кабель, значение каждого автомата на щитке в стойке, а также каждое устройство.

Маркировка кабелей заземлени
Маркировка кабелей заземления

Список VLAN

Каждая группа будет выделена в отдельный влан. Таким образом мы ограничим широковещательные домены. Также введём специальный VLAN для управления устройствами. Номера VLAN c 4 по 100 зарезервированы для будущих нужд.

Список VLAN
№ VLAN VLAN name Примечание
1 default Не используется
2 Management Для управления устройствами
3 Servers Для серверной фермы
4-100   Зарезервировано
101 PTO Для пользователей ПТО
102 FEO Для пользователей ФЭО
103 Accounting Для пользователей Бухгалтерии
104 Other Для других пользователей

IP-план

Пространство меток

Как уже было сказано выше, может существовать 2^20 меток.

0: IPv4 Explicit NULL Label. «Явная пустая метка». Она используется на самом последнем пролёте MPLS — перед Egress LSR — для того, чтобы уведомить его, что эту метку 0 можно снять, не просматривая таблицу меток (точнее LFIB).Для тех FEC, что зарождаются локально (directly connected) Egress LSR выделяет метку 0 и передаёт своим соседям — предпоследним LSR (Penultimate LSR).

1: Метка Router Alert Label — аналог опции Router Alert в IP — может быть где угодно, кроме дна стека. Когда пакет приходит с такой меткой, он должен быть передан локальному модулю, а дальше он коммутируется в соответствии с меткой, которая была ниже — реальной транспортной, при этом наверх стека снова должна быть добавлена метка 1.

2: IPv6 Explicit NULL Label — то же, что и 0, только с поправкой на версию протокола IP.

Предлагаем ознакомиться:  Снасти для течения

3: Implicit Null. Фиктивная метка, которая используется для оптимизации процесса передачи пакета MPLS на Egress LSR. Эта метка может анонсироваться, но никогда не используется в заголовке MPLS реально. Рассмотрим её попозже.

4-15: Зарезервированы.

В зависимости от вендора, могут быть зафиксированы и другие значения меток, например, на оборудовании Huawei метки 16-1023 используются для статических LSP, а всё, что выше — в динамических. В Cisco доступные метки начинаются уже с 16-й.

=====================Задача № 2

На следующей схеме все маршрутизаторы, кроме R5, это маршрутизаторы Huawei. R5 — Cisco.

Сети для самых маленьких. Часть 0. Планирование || Сети для маленьких

Для приведенной ниже конфигурации маршрутизатора R5, необходимо настроить его таким образом, чтобы распределение значений меток соответствовало Huawei. Речь о том, что в Huawei динамические метки начинаются с 1024, а в Cisco с 16.

Конфигурация R5

ip cef
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 ip router isis
!
interface FastEthernet0/0
 description to R4
 ip address 10.0.45.5 255.255.255.0
 ip router isis
 mpls ip
!
interface FastEthernet0/1
 description to R2
 ip address 10.0.25.5 255.255.255.0
 ip router isis
 mpls ip
!
interface FastEthernet1/0
 description to R6
 ip address 10.0.56.5 255.255.255.0
 ip router isis
 mpls ip
!
router isis
 net 10.0000.0000.0005.00
!
mpls ldp router-id Loopback0 force

Подробности задачи тут.=====================

В целом стало понятно, как передаётся трафик и как в этом участвуют метки MPLS.Но метки не берутся от балды — никому не нужен дополнительный хаос в преддверии Нового Года. Специальные протоколы распределяют метки между Egress LSR и Ingress LSR, создавая LSP.

Ссылка на основную публикацию
Adblock detector